WordPress for iOS 4.0.1 Released

Posted on 8 Apr 14 by Sendhil Panchadsaram

WordPress for iOS 4.0.1 is out and now available to download from the App Store.

Some of the updates included are:

  • Improved the performance of stats.
  • Made the “Options” page easier to locate and access.
  • Fixed a bug that caused the app to freeze when you tried to update a post’s settings.
  • Fixed a bug that stopped you from moving the cursor to the end of a line.
  • Fixed a bug that broke the UI when you inserted a link in the post editor.
  • Fixed a bug that crashed the app when you added a featured image to a post.
  • Increased the minimum required version of WordPress to 3.6.
  • Fixed a bug that caused the post editor to malfunction if you inserted a link.

What’s Next?

We’re hard at work on the next major version of the app (4.1), where we’re working through your feedback to make big improvements to working with media. The post editor is getting better media management features, including the ability to easily attach media that’s already been uploaded to your blog. For a sneak peek, take a look  here.

A huge thanks to our contributors who worked on this release: @itsaboutcode, @koke, @astralbodies, @aerych, @sendhil.

Have feedback? Leave a comment below or tweet us @WordPressiOS

Follow any comments here with the RSS feed for this post.

30 Responses to “WordPress for iOS 4.0.1 Released”

  1. cb

    The Preview failure / Certificate error issue has not been resolved.

    http://contrafactual.com/2014/04/07/iphone-app-previewcert-error/

    1. Sendhil

      Hi cb – we are aware of that one and will resolve it for the next release.

      1. cb

        Excellent, thanks. My post lists a workaround 🙂

        1. Sendhil

          Thanks for the work around! If you want you can track this issue here – https://github.com/wordpress-mobile/WordPress-iOS/issues/1520.

  2. Sahmiieh

    Another issue about photos added in a post and published through iOS devices: It seems the photos will be listed as “unattached” to any posts, and when I apply the [gallery] code to the content it then casuses the images to be hidden! It used to work fine in previous releases, how come this time it doesn’t work?

    1. Sendhil

      Hi Sahmiieh,

      Sorry to hear that. Is your blog on WordPress.com or is it a self hosted blog?

      1. Sahmiieh

        Hi Sendhil,
        It is a WordPress.com blog.

        1. Sendhil

          Could you try logging out of your blog, re-logging back in, upload a photo and let me know if the problem still persists?

          1. Sahmiieh

            Just tried and yup, still having the same problem.

            1. Sendhil

              Sorry to hear that. We’ve created an issue and will tackle it asap.

  3. cb

    Rats … 4.0.1 no longer allows me to schedule posts on the future.

    ALL new posts are Immediate.

    😦

    I used that feature a lot.

    1. Sendhil

      Oof – we’re sorry about that. I was able to reproduce that just now. We’ll fix that immediately and get out a hot fix asap.

  4. cb

    4.0.1 scrolling is glitchy. While editing a long post in portrait mode, rapid scrolling to the top (or bottom?) causes as reset back to the bottom (or top). Like a “Ground Hog Day” for scrolling (keeps repeating at the same place).

    1. Sendhil

      Hi cb – could you go into more detail? What do you mena that rapid scrolling to the top “causes as reset back to the bottom”?

  5. cb

    Beta testers …

    How do I apply to become one?

    I seem to turning over all the stones with “treasures” hidden under them.

    1. Sendhil

      Hey CB – shoot me an email at sendhil AT automattic.com.

  6. Sarah Kalemkiarian

    I seem to be unable to login using the app with my iPad. It tells me I have the correct username and password (I even logged in through my computer and created a new account to try which doesn’t work either!) Not sure what to do, I can log in using Safari and going to the site but the app will not allow me to even login.

    HELP!!

    1. Sendhil

      Hi Sarah,

      Is your blog on WordPress.com or is it on a self hosted blog? If it’s on WordPress.com do you have two factor authentication setup?

  7. cb

    http or https?

    The iOS app post editor 4.0.1 forces all occurrences of http or https to https

    Is this by design or defect?

    1. Sendhil

      This is a bit of a flaw that’s causing some of the problems people are having when they preview posts in the app right now or view the site. As far as the beta test stuff, I got your email and will respond soon.

  8. esszymanski

    Hi there,
    I cannot get my wordpress app to work properly. I am subscribed to two blogs and only two posts will open from “one” of the blogs on my iphone 5. If I try to scroll down, its just blank. I have the most recent of the wordpress app (4.0.1), ive tried restarting my phone several times. So, I know something is seriously wrong with the app. Also, when I try to put in my username/password/ web address for the second blog I subscribe to, it just flashes on my screen and takes me back to my homepage….Help???!?!??!

    1. Sendhil

      Hi there,

      Sorry to hear you are having trouble. Are your blogs on WordPress.com or are they self hosted?

      1. esszymanski

        Hi there. Im not sure but these are the websites:
        http://Www.sunflowerhomejournals.com
        http://sogladimhere.wordpress.com

        The second one is the one that wont show up at all when i enter the website and the screen just flashes and leaves the app.

        Can you help?!

      2. esszymanski

        You never responded after i sent my answers. Can you please respond and help me? Pls email me at esszymanski@gmail.com

        1. Sendhil

          HI there – sorry about that. Could you do us a favor? Would you mind removing the app, re-installing it, logging into both and then letting me know if the problem still persists?

  9. cb

    4.0.2 is out

    It fixes the scheduling and preview issues

    Woo Hoo!

    1. Sendhil

      Glad to hear it!

  10. mrstraceyryanTracey

    I attempted to update wordpress tonight, received fatal error messages. I had just posted a new entry which did not post to my media avenues and the site is not working at all now. Message given internal server error.

    1. Sendhil

      Sorry to hear that. Could you try uninstalling the app, re-installing it and letting us know if the problem persists?

%d bloggers like this: